Strange UI error

SOLVED

For one specific user, when opening PJC timecards, the UI wants to insert an inactive employee number by default. It errors out. Tried resetting defaults for the UI, no success. Tried recreating the users *.ism files, no success. User has full admin rights to the PJC module. No UI customizations in place

Top Replies

Parents
  • Hi  I'll confirm what you've tried and give some suggestions on what I can think of.  Like many of us here we've run into similar issues from time to time...

    First up can I confirm you right-clicked on the screen icon, selected Restore Defaults, ticked everything and clicked OK?

    And also to confirm you have renamed, deleted or replaced from another user all WID_P.ism files?  Have you tried deleting the users folder all together and have them log in again and try?

    If the user can get to the Employee Number finder, have they tried clicking Set Criteria -> Clear -> Save to ensure the finder isn't default to Employee 407 automatically?

    Have you tried the duplicate icon trick (often works for these issues)? You can do this under your admin account with the 'All Users' option. To do this right-click Copy the Timecards icon, right-click on some white space, left-click New -> Folder -> name it -> OK, then open the folder and right-click paste a fresh Timecards icon into it.  This one shouldn't be corrupt and should just work:

    Have you tried clearing all Restart Records under Administrative Services -> Restart Maintenance in case there is a partially failed Timecard import or something (I know its a stretch but trying to think of anything)?


    Finally can you just make employee 407 active again temporarily?

    If you can't work it out, please send a screenshot of the User's Employee Number finder (if you can open it).

    I can't think of where else might be setting this for now.  Let us know how you go!  Good luck!

  • 0 in reply to Accsys Consulting AU

    I had previously tried all of the above suggestions. One exception was when I duplicated the icon, I didn't put it in a new folder, and I haven't deleted the entire users folder. I'll giver those two a try tomorrow

  • 0 in reply to Darren Williams

    I actually just tried both the suggestions I hadn't tried yet and neither worked (recreating icon in new folder and deleting user folder)

    I forgot to grab a screenshot of the employee number finder, but there wasn't anything unusual I could see.

  • 0 in reply to Darren Williams
    SUGGESTED

    Wow  !  Ok lets flip this troubleshooting so we can work it out.

    1. Sage 300 Profile - does the issue occur if the user logs in under a different non-affected Sage 300 user or as ADMIN, but still using the affected users Windows profile?
    2. Windows Profile - does the issue occur if the affected Sage 300 user logs in under a different Windows profile using their affected Sage 300 profile?
    3. Workstation/RDS - If you have more than one RDS server or Workstation, does the issue occur if the affected user logs in via a different RDS or Workstation?
    4. Is only one company affected?  If you dump and load the data into a test database and the user logs into that, does the error still occur?  Does it occur in other companies?
    5. Have you run a Data Integrity check in Admin Services for the PJC module?  (long shot but might identify the error).
    6. Can you please start RVSPY then re-create the error, capturing the event in the log, then share the lines in the log where the issue occurs?  Or share the whole log if you're not sure.

    If you can isolate the issue or identify it in RVSPY it will be a big help.

    Good luck!

  • 0 in reply to Accsys Consulting AU

    1. No it doesn't

    2. Yes it does

    3. One RDS only

    4. Multiple companies affected for that user only. The really odd thing is that in a different company the employee ID is different. For example, I saw 406 instead of 407.

    5. Haven't tried that, but I'll give it a whirl

    6. RVSPY attached


    rvspy.txt

  • +1 in reply to Darren Williams
    verified answer

    Well, the answer was so simple it was completely overlooked. 

    The affected user ID was listed as the USER ID in the PJC employee for multiple employees

Reply Children
No Data