Intelligence Report Error - Automation Failed - Report Design Add-In

SOLVED

I am using Pastel Express with the Intelligence Reporting Module.

I can export a report to Excel (Management Pack D2-7) but when requesting to run an Inc Stmt where Budget details are required and variance to Actual, I get "An Automation Failed"error.

I have checked for fixes on this and I noted on my Excel although I have the "BI Generator" as an Add-In, I do not have the "Report Designed Add-In" function available in Excel.  Not sure if this is the cause of the error?

Can anyone advise how I can add this to Excel, it does not appear on my Add-In lists on Excel - only the "BI Generator" is available on the list.

I am using Office365 - one of my other PC's still use Office 2010 and the functionality works fine on that PC.

Thanks for your help

Albert

Parents
  • 0
    verified answer

    Good day Albert,

    The add-ins are missing in the Report Designer.

    Please follow the steps below to resolve the issue:

    In Excel, add the Common Files Folder to the Trusted Sites
    Open a blank Excel file
    Click on File > Options > Trust Center > Trust Center Settings > Trusted Locations > Add new location > Browse to 'C:\Program Files (x86)\Common Files'
    Click on OK
    Click on 'Subfolders of this location are also trusted'
    Click on OK
    Verify if the Report Designer Add-In (Custom Task Pane Helper) and the BI Generator Add-In are enabled through the Excel > Options > Add-Ins menu

    Should the error persist, run pending Office/Windows updates (Your IT person can assist with the process) and try again. Otherwise, have Excel repaired on your machine/s.

    Please verify or reply and let us know if the advice/suggestion provided was helpful.

    To verify an answer simply go to your post and click “More” > “Verify Answer” 

    Kind Regards.

  • 0 in reply to Lolo

    Thanks for the assistance - it partly resolved my issue - I think my issue may be an Office installation problem.  I have re-installed Office - but the system remains on my PC - the error is similar to last time and also gives FA error.  I do not think it is an Office 365 issue as it does work on another PC.  I attach a screen shot of the FA error.

    It only gives an error if any report is run where the Budget is involved - all other reports work fine.

    Thanks again for assistance.

  • 0 in reply to AlbertH

    Good day Albert,

    Please follow the steps indicated in the link below for further assistance.

    https://za-kb.sage.com/portal/app/portlets/results/viewsolution.jsp?solutionid=200203062939685&page=1&position=8&q=Intelligence%20

    Please verify or reply and let us know if the advice/suggestion provided was helpful.

    To verify an answer, simply go to your post and click "More" > "Verify Answer." 

    Kind regards,

  • 0 in reply to Lolo

    Thanks for the feedback - I have followed your steps - unfortunately problem not resolved, please refer to the screenshots of errrors received.

    This was received , I accepted to continue and it extracted to Excel.

    I was able to prepare and Inc Stmt of Actuals only as well as one of Actual and Prior - it ran perfectly, even though the error on extraction was listed.

    I then tried to run an Inc Stmt with Budget details as well, it did not finish, following error was received.

    Thanks again for the feedback on this.

  • 0 in reply to AlbertH

    Good day Albert,

    Please forward your query to [email protected] for further assistance on this query. 

    Please verify or reply and let us know if the advice/suggestion provided was helpful.

    To verify an answer, simply go to your post and click "More" > "Verify Answer." 

    Kind regards,

Reply Children
No Data