Sage Intelligence won't open on my stand alone system


Windows 11 laptop, with Sage 100 versions 2020 Std, 2021 Adv and 2022 Prem installed and functioning fine. Sage Intelligence will not open any task in any of these versions. It's been a while since I have opened SI on my laptop, but it was working in at least 1 or 2 previous iterations of Sage 100. Now nothing at all happens in either version. I have rerun workstation setup. Excel opens up fine. BI Generator and a couple of Report Designer Add-Ins are Active in Excel.

  • 0

    An update to this is that I have just added Sage 100 Adv 2023 to my system and, in this new version, Sage Intelligence now opens and populates reports. Not sure if the older versions are going to correct themselves, but as long as I can open these up in 1 version I guess I'm happy. 

  • 0 in reply to rclowe

    Hello, I have the same issue. I have v2021, v2022 and v2023 on my laptop and cannot open Sage Intelligence in any version. Checked permissions, have run as admin and tried uninstalling, reinstalling. Made myself local admin. Have all the right permissions. The windows log says something about net framework. Did you ever find out more about why it was happening? Even after installing v2023 on mine it still won't open.

  • 0 in reply to dhalpin

    Sage Intelligence requirements

    As with any software program, it's important to know the required prerequisites for Sage Intelligence custom reporting to allow it to function without issue.


    • Sage Intelligence must be installed as the Network Administrator
    • Excel must be installed and activated prior to the Sage Intelligence installation
    • Excel must be closed during installation of Sage Intelligence (also check that there are no remaining EXCEL.EXE processes listed in the Windows Task Manager-Processes tab)
    • Windows User Account Control must be turned off during installation


    • Microsoft V.S.T.O. (Visual Studio Tools for Office) runtime 2010 must be installed
    • Microsoft V.S.T.O. runtime 3.0 must be installed


    • All Sage Intelligence users must have Full Control level permissions to the following areas:
    1. MAS90 parent directory (as is also normally required for Sage 100/MAS90)
    2. The Sage Intelligence Report Repository (set by users)
    3. All folders that begin with 'BI' and located in C:\Program Files(x86 if applicable)\Common Files\ (screenshot below reflects latest 2015 release, your install may have fewer folders starting with 'BI')
    • As with all permissions, if you have a group policy or domain, those settings must reflect the above requirements
    • If you are running in a terminal services or Citrix environment, please see the attached document

    Report Repository

    • Must be set as a UNC path on a shared network drive (cannot browse through a Mapped Drive to select location either)


    • Make sure you are running a compatible version of Excel (Office 365 is not compatible; 64-bit versions of Excel are compatible with Sage 100 2014 and newer only)
    • V.B.A. components must be installed in Excel (run a repair/change install of Excel from Control Panel, see screen-shots below)

    s the new name for Sage City
  • 0 in reply to Doc102208

    it might be worth mentioning as a side note in regard to Windows 11, that the Integrated Solutions Compatibility Matrix for Sage 100 2024 and older shows this for Sage 100 Intelligence Reporting (regarding Windows versions supported): 

  • 0 in reply to DGR

    Finally figured this out. On my old laptop the report repository had c$ (\\localhost\c$\2015Repository) in it and SI worked fine. When I got my new laptop I copied the config.ini from the old laptop to the new one and even though it was a valid path on the new laptop and all permissions were set, SI would not open. On new laptop I edited the config and took out the "$" in the path and then SI opened but it didn't like the path still so I shared out the folder and changed the report repository to the shared path and now all works on new laptop.

  • 0 in reply to dhalpin

    The C$ paths are special Windows shares that are limited to local administrators.  You're probably not a local admin on the new machine.  Generally speaking, using them for normal functionality is not recommended.